进入openwrt路由安装软件时报错了,试了好几个软件都提示无法安装缺少依赖环境;

root@OpenWrt:~# opkg install luci-app-aria2
Installing luci-app-aria2 (1.0.1-2) to root...
Downloading http://mirrors.tuna.tsinghua.edu.cn/lede/releases/18.06.2/packages/mips_24kc/luci/luci-app-aria2_1.0.1-2_all.ipk
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-app-aria2:
 * 	aria2
 * opkg_install_cmd: Cannot install package luci-app-aria2.

折腾了一阵之后发现是软件源太旧了,官方不再维护所致;目前官方已经推出了18.06.5,而我的路由上还在使用18.06.4所致。

所以替换成官方最新的镜像源,然后执行opkg update更新一下系统让其生效;